- Local time
- Nov 20, 2019
Sorry if it seems like im always asking for help!
Im attempting to dive deep into learning frameworks and general webdev tools, im attempting to follow this tutorial:
Symfony Tutorial: Building a Blog (Part 1)
Which I unserddstand so far but im running into an issue when I get to the section where I need to run this command:
composer require hwi/oauth-bundle php-http/guzzle6-adapter php-http/httplug-bundle
it fails and reverts my composer.json with this error message:
Using version ^0.6.3 for hwi/oauth-bundle Using version ^2.0 for php-http/guzzle6-adapter Using version ^1.16 for php-http/httplug-bundle ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) Restricting packages listed in "symfony/symfony" to "5.0.*" Your requirements could not be resolved to an installable set of packages. Problem 1 - Installation request for hwi/oauth-bundle ^0.6.3 -> satisfiable by hwi/oauth-bundle[0.6.3]. - hwi/oauth-bundle 0.6.3 requires symfony/framework-bundle ^2.8|^3.0|^4.0 -> no matching package found. Problem 2 - Installation request for php-http/httplug-bundle ^1.16 -> satisfiable by php-http/httplug-bundle[1.16.0]. - php-http/httplug-bundle 1.16.0 requires symfony/config ^3.4.20 || ^4.2.1 -> no matching package found. Potential causes: - A typo in the package name - The package is not available in a stable-enough version according to your minimum-stability setting see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details. - It's a private package and you forgot to add a custom repository to find it Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
Any suggestions on how I can go about troubleshooting this, my first though was to install symfony/framework-bundle and symfony/config but that didnt seem to work either!
Any help/suggestions greatly appreciated!